Forum

Moderiert von: stefan, spinne
Forum Index
Support
     Administration
     Registrierung: E-Mailadresse des Absenders?
 

Seite 1 2 3 vorherige Seite 


Autor Registrierung: E-Mailadresse des Absenders?
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 26.09.2010 14:05

Hallo Stefan,
herzlichen Dank für die rasche Reaktion/Lösung!

Ich zieh' mir gerade den aktuellen Trunk aus dem SVN ab & werde mir dann die geänderte functions.php drüberknallen & Dir dann bescheidgeben.

Ciao,
Boby
[addsig]

Zitieren nach oben
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 26.09.2010 15:34

Also wenn mein Vorgehen (neue functions.php zu überspielen) nicht verwerflich ist, dann ist der Fehler nicht vollständig ausgebessert.

Fehler kommt jetzt keiner Mehr - aber Mails kommen auch nicht an.

Kann ich das irgendwie debuggen?

Sorry,
Boby
[addsig]

Zitieren nach oben
stefan
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 26.09.2010 15:43

hmm bei mir ging es dann.

Geh mal auf labor und schau nach den Abo's. Damit die wieder zurückgesetzt sind.

Im Admin kannst du unter Einstellungen->eMail

Email Debugging aktivieren?

Ein debuging aktivieren.

Dann wird beim senden von eMails per smtp alles ausgegeben was passiert.

Wenn du dann ein Beitrag verfasst sollte eine Benachrichtigung Versand werden (ich hab das auch im Abo)

Ich hatte das mit 2 Benutzern getestet

Sofern du deine Abos abgeholt hast kann ich auch noch mal Posten oder du legst dir noch einen weiteren User an.


Zitieren nach oben
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 26.09.2010 21:08

Hallo Stefan,
es hat nun offenbar doch geklappt (dürfte nur ein paar Minuten Verzögerung gegeben haben).

Ich werde mal die anderen User fragen, ob sie Mails bekommen haben.

Noch eine Frage:
Wo in der DB kann ich nachsehen, wer aller welche Themen abonniert hat? Oder gibt's eine übersichtliche Aufstellung in OPN selbst?

Danke nochmals & liebe Grüße,
Boby
[addsig]

Zitieren nach oben
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 26.09.2010 22:19

Boby schrieb am 26.09.2010 um 21:08:21 Uhr folgendes:

Wo in der DB kann ich nachsehen, wer aller welche Themen abonniert hat?

opn_forums_forum_watch bereits gefunden
[addsig]

Zitieren nach oben
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 27.09.2010 20:54

Hallo,
jetzt hätte ich noch eine Frage:
Prinzipiell funktionert alles. Allerdings habe ich einen User, der ein Forum abonniert hat.

Wenn ich in einem solchen Forum antworte, passiert das:

ERROR [2] unable to add recipient[stinson@drei.at]
FOUND IN [class/mail/class.opn_mail_smtp.php]
FOUND AT 244

Daraufhin hat dieser User in der Tabelle opn_forum_forums_watch bei dem Forum, wo's eckt, im Feld notify_status = 1 stehen.
Sobald dieser 1er drinnen steht, versucht OPN gar nicht mehr, den User anzuschreiben. Stelle ich das Flag wieder in der DB auf 0, dann kommt diese Fehlermeldung.

Hätte wer einen Tipp für mich, woran das Problem liegen könnte? (möchte es nur verstehen)

Danke & LG,
Robert
[addsig]

Zitieren nach oben
stefan
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 28.09.2010 04:46

Das 1 bedeutet ja nichts anderes das bereits eine Meldung versand wurde. Wird dann nochmal geantwortet soll es ja keine weitere geben. Erst wieder wenn er es gelesen hat und dann kommt was neues.

Zum eMail error

Das bedeute dein Server hat diese Adresse nicht akzeptiert. Wieso er das nicht will müsstest du mal im eMail debuging Modus ansehen.


Zitieren nach oben
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 04.10.2010 21:02

Hallo Stefan,
ich bekomme vereinzelt beschwerden, dass User keine Mails bekommen - das trifft aber nur mehr einzelne.

Am Mail-Server liegt's m.E. nicht - wenn ich mit dem Account einsteige & das Mail an die gewünschte Adresse schicke, kommen sie an.

E-Mail-Debugging ist aktiviert - wo kann ich mir die "Logs" nachträglich ansehen? Im Errorlog dürften sie ja nicht landen...,

LG,
Robert
[addsig]

Zitieren nach oben
Gast
Unregistrierter Benutzer
Registrierung: E-Mailadresse des Absenders?

Geschrieben: 29.10.2010 17:32

Aktueller Status - und Dank an Stefan:
1) Das Problem war, dass ich zwar für den Mail- Account "SMPT" korrekt eingereichtet war, aber beim Login "SMTP-Server entscheide" ausgewählt hatte. Das hat bei einigen Providern funktioniert, bei anderen nicht. Besser ist es hier "LOGIN" zu verwenden => dann klappts immer
2) Stefan hat noch zwei Dinge erweitert:
a) Fehler beim Mailversand kommen jetzt auch ins Errorlog (wurden bis dahin immer nur am Schirm angezeigt)
b) Es gibt jetzt auf der "Diagnostic"-Seite die Möglichtkeit, Mails an eine BELIEBIGE Adresse zu schicken.

Danke nochmals an Stefan!

Ciao,
Boby
[addsig]

Zitieren nach oben
sortieren nach
Seite 1 2 3 vorherige Seite 

 
Vorheriges Thema:  interne Mail versenden - Frage
Nächstes Thema:  Ausgesperrt

Gehe zu: