Forum

Moderiert von: stefan, spinne
Forum Index
Support
     Installation und Update
     OPN Installations-Problem
 

Seite 1 2 nächste Seite 


Autor OPN Installations-Problem
N-kay

Registriert: 08.01.2010
Beiträge: 11


Sende eine Private Nachricht an N-kay
Geschrieben: 09.01.2010 14:47

Ich versuche, auf meiner Webspace OPN zu installieren, scheitere aber schon gleich am Anfang.
Ich habe in der mainfile.empty meine Daten eingetragen, sie in mainfile umbenannt, aber da scheint irgent etwas nicht zu stimmen...
Die Fehlermeldung könnt ihr euch direkt hier ansehen.
Und so sieht meine mainfile.php aus:
[code]<?php
/*
* OpenPHPNuke: Great Web Portal System
*
* Copyright (c) 2001-2010 by
* Heinz Hombergs heinz@hhombergs.de
* Stefan Kaletta stefan@kaletta.de
* Alexander Weber xweber@kamelfreunde.de
*
* This program is free software. You can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation; either version 2 of the License.
* See LICENSE for details.
*
* This software is based on various code found in the internet
* See CREDITS for details
* If you are an author of a part of opn and not you are not mentioned
* SORRY for that ! We respect your rights to your code, so please send
* an eMail to devteam@openphpnuke.com we will include you to the CREDITS asap
*/

/* Database & System Config
*
* dbhost:   MySQL Database Hostname
* dbuname:  MySQL Username
* dbpass:   MySQL Password
* dbname:   MySQL Database Name
* system:   0 Crypt (*nix), 1 for Text (*nix/Windows), 2 for MD5 (*nix/Windows)
*/

$dbhost = 'rdbms.strato.de';
$dbuname = '**********';
$dbpass = '***************';
$dbname = '*********';
$system = 2;
$opn_tableprefix = 'opn_';
$dbdriver = 'mysql';
/* physical path to your main opn directory with a trailing slash */

$root_path = 'http://roflcore.de/';

/* Needed only when installed in a subdir.
*  i.e. /server/www/opn
*  $installdir = 'opn';
*  /server/www/cms/opn
*  $installdir = 'cms/opn';
*/

$installdir = 'http://roflcore.de/install/';

if ($dbname == '')  { die(); }

((int)include($root_path."master.php")) or die ("<br /><strong>Error: can't find master.php <br />- openPHPnuke is not correctly installed - </b><br /><br /><br /> your root_path is set to '' but this seems that this is not ok<br />edit the /mainfile.php to set this path<br /><br /> or <br /><br />run install.php to install openPHPnuke");

?>


Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 09.01.2010 15:30

$root_path = 'http://roflcore.de/';


der Pfad stimmt nicht

da kommt rein:

/mnt/web4/21/87/52171387/htdocs/N-kay/


Flash
[addsig]

Zitieren nach oben
N-kay

Registriert: 08.01.2010
Beiträge: 11


Sende eine Private Nachricht an N-kay
Geschrieben: 09.01.2010 15:38

Danke für den schnellen Support, aber jetzt kommt das nächste Problem, siehe wieder roflcore.de


Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 09.01.2010 15:59

Da hast du was bei der Installation falsche eingegeben.


die Pfade stimmen nicht.

Am besten nochmal neu installieren und erst bei Schritt 3 was ändern.
Bei Schritt 1+2 die Pfade nicht ändern, da OPN die schon korrekt ausliest.

Falls es nicht geht, dann kannst du per PM die Zugansdaten senden, wir werden es dir installieren.

Flash

[addsig]

Zitieren nach oben
N-kay

Registriert: 08.01.2010
Beiträge: 11


Sende eine Private Nachricht an N-kay
Geschrieben: 09.01.2010 16:38

Ok, der nächste Fehler:
Bei Schritt 7/8 bekomm ich folgendes ausgespuckt:

[code[make_dir(php): could not create dirname: /mnt/web4/21/87/52171387/htdocs/N-kay/cache/opn_templates_compiled_1263053328

make_dir(php): could not create dirname: /mnt/web4/21/87/52171387/htdocs/N-kay/cache/opn_templates_1263058929
[/code]


Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 09.01.2010 19:00

okay, das ist weiter noch nicht schlimm

OPN sollte aber nun trotzdem laufen.

Kommst Du in den Admin Bereich?


Flash
[addsig]

Zitieren nach oben
N-kay

Registriert: 08.01.2010
Beiträge: 11


Sende eine Private Nachricht an N-kay
Geschrieben: 09.01.2010 19:40

Sobald ich mich anmelde, bekomm ich eine ganze Reihe Errors:



WARNING [8] Undefined index: user_group
FOUND IN [class/class.opn_permissions.php]
FOUND AT 1002


WARNING [8] Undefined index: user_group
FOUND IN [class/class.opn_permissions.php]
FOUND AT 1003


WARNING [8] Undefined index:
FOUND IN [class/class.opn_permissions.php]
FOUND AT 1003


WARNING [8] Undefined index: uname
FOUND IN [class/class.opn_permissions.php]
FOUND AT 1004


WARNING [8] Undefined index: user_group
FOUND IN [class/class.opn_permissions.php]
FOUND AT 1149


WARNING [8] Undefined index:
FOUND IN [class/class.opn_permissions.php]
FOUND AT 1149


WARNING [8] Undefined index: uid
FOUND IN [class/class.opn_permissions.php]
FOUND AT 139


ERROR [512] mysql error: [1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY perm_id' at line 1] in EXECUTE("SELECT perm_module, perm_rights FROM opn1_user_rights WHERE perm_uid= ORDER BY perm_id ")
FOUND IN [include/opndb-errorhandler.php]
FOUND AT 253


WARNING [8] Undefined index: uid
FOUND IN [master.php]
FOUND AT 455


ERROR [512] mysql error: [1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1] in EXECUTE("SELECT user_status FROM opn1_opn_user_dat WHERE user_uid=")
FOUND IN [include/opndb-errorhandler.php]
FOUND AT 253


WARNING [8] Undefined index: uid
FOUND IN [class/class.opn_permissions.php]
FOUND AT 812

Und darunter seh dann noch folgendes:



Ziemlich schwere Geburt, das alles...
Aber danke nochmal für deinen Support



Zitieren nach oben
spinne
Registriert: 21.08.2003
Wohnort: Luzern


Sende eine Private Nachricht an spinne Besuche die Homepage von spinne
Geschrieben: 10.01.2010 09:27

hier solltest du die cookies löschen dann solltest du in den admin kommen resp dich anmelden können


Zitieren nach oben
N-kay

Registriert: 08.01.2010
Beiträge: 11


Sende eine Private Nachricht an N-kay
Geschrieben: 10.01.2010 13:01

Gut, wieder einen Schritt weiter, wenn ich dann also Ins Adminmenü gehe, bekomm ich gleich wieder 2 schöne Meldungen, sonst nichts:

ERROR [2] install.php bitte loeschen !!!
FOUND IN [Im Root Verzeichnis]
FOUND AT


ERROR [2] fopen(/mnt/web4/21/87/52171387/htdocs/N-kay/cache/opn_templates_compiled_1263053328/opnadminmenu_html.php) [function.fopen]: failed to open stream: No such file or directory
FOUND IN [class/smarttemplate/class.smarttemplateparser.php]
FOUND AT 277

SmartTemplate Compiler Error: Could not write compiled file.

Das 1. ist zu verstehen, beim 2. findet er eine Datei nicht, die wohl nicht erstellt werden konnte... Aber der gesamte Ordner Cache und ALLE Unterordner und Dateien haben 777 Rechte( wobei das nur 2 Dateien sind, eine leere copy.txt und eine index.html)


Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 10.01.2010 13:50

2. findet er eine Datei nicht, die wohl nicht erstellt werden konnte... Aber der gesamte Ordner Cache und ALLE Unterordner und Dateien haben 777 Rechte( wobei das nur 2 Dateien sind, eine leere copy.txt und eine index.html)


genau, beim zweiten Fehler stimmen die Rechte nicht vom Server.

Das kannst du in Admin - Einstellungen - Server ändern

Was sagt denn nun der Config Test?

Habe dir gestern ein PM gesendet.

Flash





[addsig]

Zitieren nach oben
sortieren nach
Seite 1 2 nächste Seite 

 
Vorheriges Thema:  OPN Installation Fehlermeldung
Nächstes Thema:  fehler nach installation im intranet

Gehe zu: