Forum

Moderiert von: stefan, spinne
Forum Index
Support
     Bug oder nicht...
     Seltsames Problem
 

Autor Seltsames Problem
Gast
Unregistrierter Benutzer
Geschrieben: 29.08.2013 22:52

ERROR [2] preg_replace_callback() [function.preg-replace-callback]: Requires argument 2, 'self::_calcSubInterval', to be a valid callback
FOUND IN [class/class.opn_date.php]
FOUND AT 727
ERROR [512] mysql error: [1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '.00000 AND 2456534.82134.99999)) GROUP BY user_regdate ORDER BY user_regdate' at line 1] in EXECUTE("SELECT user_regdate, count(u.uid) AS counter FROM opn_users u, opn_users_status us WHERE us.uid=u.uid and us.level10 and u.uid 1 and ((user_regdate BETWEEN 2456534.00000 AND 2456534.99999) or (user_regdate BETWEEN 2456534.82134.00000 AND 2456534.82134.99999)) GROUP BY user_regdate ORDER BY user_regdate")

zu finden auf www.rc-boote.at

Bitte um Hilfe!

Danke,
Boby

[addsig]

Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 30.08.2013 22:52

Hi,
kann mir keiner helfen?
Ich hab nichts verändert...

Danke,
Boby
[addsig]

Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 31.08.2013 20:51

Hallo,
ich konnte es soweit eingrenzen, dass die class opn_date offenbar geändert wurde - und Zeile 727 das Problem verursacht. Habe sie jetzt mal auskommentiert...bitte beizeiten um Behebung - die Datei wurde am 29.08.13 geändert - ich vermute mal von Stefan

Danke & liebe Grüße,
Boby


Zitieren nach oben
stefan
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 01.09.2013 18:47

Richtig hier läuft es auch so.

Das ist eine Änderung um auch unter PHP 5.5.x lauffähig zu sein.

Deine Meldung

Requires argument 2, 'self::_calcSubInterval'

Sagt aus das die _calcSubInterval 2 Argumente braucht.

In der alten Version was das so aber eigentlich ist die auch geändert. Aktuell steht da bei mir jedenfalls

function _calcSubInterval ($matches) {

also ein Argument....

komisch ...


Zitieren nach oben
stefan
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 01.09.2013 19:34

OK Sorry ich hatte nicht gedacht das noch PHP 5.2 genutzt wird.

Muss ich auf die Version 5.2 anpassen.


Zitieren nach oben
Gast
Unregistrierter Benutzer
Geschrieben: 02.09.2013 19:13

Okay, danke für den Hinweis - ich werde demnächst auf PHP 5.4 umziehen.

LG,
Boby


Zitieren nach oben
sortieren nach

 
Vorheriges Thema:  Fehler in Forums-Box
Nächstes Thema:  FCKEditor und IE10

Gehe zu: