Forum

Moderiert von: Flash, spinne
Forum Index
Templates / Themes
     Themes Import
     joomla theme emulator
 

Autor joomla theme emulator
stefan
Beiträge: 2436
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 20.01.2007 16:08

auf wunsch eines einzelnen habe ich mal einen prototyp einen joomla theme emulator in das experimental svn gestellt.

dieses muss logischer weise noch massiv verbessert werden. sofern ein joomla kennen sagt welche css classe wo falsch ist oder ich falsch verstanden habe werde ich es entsprechend anpassen



Erst nachlesen, dann nachdenken, dann nachfragen...
http://www.catb.org/~esr/faqs/smart-questions.html

openPHPnuke Developer

Zitieren nach oben
Texx

Registriert: 24.07.2006
Beiträge: 19


Sende eine Private Nachricht an Texx
Geschrieben: 21.01.2007 17:26

Ich weiß jetzt nicht obs dir direkt weiterhilft aber ich hab da eine Doku zum Joomla-Templatesystem gefunden.

http://www.joomla.de/content/view/88/17/

MFG Texx


Zitieren nach oben
golive
Registriert: 15.10.2001
Beiträge: 384
Wohnort: links hinter 193.28.195.10


Sende eine Private Nachricht an golive
Geschrieben: 04.04.2007 10:52

Hallo Stefan,

erstmal ein fettes Dankeschön für den ersten Prototyen des Joomlathemakonverters!

Ich habe auch schon ein erstes Mal damit herumgespielt. Ein bisschen gestöbert, ein Theme ausgesucht und war sehr gespannt: hier taucht auch schon gleich die erste Frage auf: gibt es einen bestimmten Versionskreis aus dem die Joomlathemes sein sollen?

Hintergrund:
Ich habe Tine den Sieger aus dem Februarvoting geschickt das TBC OfficeStyle Lite Theme. Für die Schweizer Spielwiese....Leider funktioniert es dort überhaupt nicht. Kann dir leider den genauen Fehler nicht sagen - mir wurden die Webmasterechte wieder entzogen...

Beim Durchsehen der restlichen Seite ist mir aufgefallen dass es unterschiedliche Versionsgruppen bei den Themes gibt....vielelicht ist ja die Ursache bzw. die einfache Lösung des Problems zu finden? Einfach ein anderes Theme verwenden?

Ansonsten ein erstes Feedback zu den beiden Themes auf OPN City.

Bei wintergrey ist das Menu innerhalb der Sidebox zuweit links.Sonst sieht es schon ziemlich gut aus.
Bei Store_Design sieht es so aus als hätte der Text keinerlei Format - wird nur in der Browserdefinierten Schriftart angezeigt....

Beiden Themes fehlen noch die Alternator.

Wie gesagt: Ich freu mich sehr! Bitte weitermachen!

Viele Grüße
go



Zitieren nach oben
spinne
Registriert: 21.08.2003
Wohnort: Luzern


Sende eine Private Nachricht an spinne Besuche die Homepage von spinne
Geschrieben: 04.04.2007 18:34

servus go,
also hm ich hab die rechte mal wieder zurück gesetzt auf wm....


Zitieren nach oben
golive
Registriert: 15.10.2001
Beiträge: 384
Wohnort: links hinter 193.28.195.10


Sende eine Private Nachricht an golive
Geschrieben: 04.04.2007 20:51

Danke Tine

da liefere ich doch mal gleich den Fehler nach:

WARNING [8] Use of undefined constant _ISO - assumed '_ISO'
FOUND IN [themes/emulator_joomla_theme/templates/tbc_officestyle_lite/index.php]
FOUND AT 4
WARNING [8] Undefined offset: 1
FOUND IN [themes/emulator_joomla_theme/templates/tbc_officestyle_lite/index.php]
FOUND AT 6
WARNING [8] Undefined variable: mainframe
FOUND IN [themes/emulator_joomla_theme/templates/tbc_officestyle_lite/index.php]
FOUND AT 23

Fatal error: Call to a member function getTemplate() on a non-object in /home/openphpn/public_html/opn/themes/emulator_joomla_theme/templates/tbc_officestyle_lite/index.php on line 23


das theme beginnt mit den folgenden zeilen:

<?php
defined( '_VALID_MOS' ) or die( 'Direct Access to this location is not allowed.' );
// needed to seperate the ISO number from the language file constant _ISO
$iso = split( '=', _ISO );
// xml prolog
echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';
?>


Schönen Abend
go


Zitieren nach oben
stefan
Beiträge: 2436
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 05.04.2007 07:22

bitte mail mir mal das theme dann schau ich mal genauer


Zitieren nach oben
stefan
Beiträge: 2436
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 05.04.2007 18:11

so mal angepasst und auf city hochgeladen. so in 20 min sollte es oben sein


Zitieren nach oben
stefan
Beiträge: 2436
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 05.04.2007 19:01

golive schrieb am 04.04.2007 um 10:52:59 Uhr folgendes:


ibt es einen bestimmten Versionskreis aus dem die Joomlathemes sein sollen?



das ist mir auch aufgefallen das die da mehere versionen haben aber ich denke das ein emulator eben alle können sollte von daher sag ich dann erstmal das ich es anpasse wenn es nötig ist

golive schrieb am 04.04.2007 um 10:52:59 Uhr folgendes:


Beiden Themes fehlen noch die Alternator.



Wenn ich das richtig sehe gibt es das bei joomla das nicht?


Zitieren nach oben
golive
Registriert: 15.10.2001
Beiträge: 384
Wohnort: links hinter 193.28.195.10


Sende eine Private Nachricht an golive
Geschrieben: 10.04.2007 08:09

ich finde die ersten Test sehen echt gut aus!

Ein bisschen Spielerei an den TPL ist vielleicht noch nötig, aber ansonsten schon sehr sehr schön!




VG
go

[ Diese Nachricht wurde bearbeitet von: golive am 10.04.2007 09:19 (Originaldatum 10.04.2007 08:09) ]


Zitieren nach oben
Flash
Registriert: 20.08.2001
Wohnort: Luzern


Sende eine Private Nachricht an Flash Besuche die Homepage von Flash
ICQ
Geschrieben: 19.06.2007 20:18

Joomla hat an der Templateengine Änderungen vorgenommen.

Die Templates sind nicht alle gleich aufgebaut. Daher funktioniert unser Emulator nicht immer Fehlerfei.

Schaut euch diesen Beitrag an.

Flash



F.L.A.S.H.: Functional Lifeform Assembled for Sabotage and Harm




OPN Themes/Templates --- Jobs Aktuell --- Geheime Gedanken --- mein spinnennetz ---
Aktuelle Jobs in der Schweiz --- RenderWorld Cinema4d Portal




Zitieren nach oben
sortieren nach

 
Vorheriges Thema:  Joomla Themen
Nächstes Thema:  Funktionieren diese Templates ?

Gehe zu: