Forum

Moderiert von: stefan
Forum Index
Entwicklerforum
     Trunk Upgrade Warning (EN & DE)
     [mcrypt] extension
 

Autor [mcrypt] extension
stefan
Wohnort: Münster


Sende eine Private Nachricht an stefan
ICQ
Geschrieben: 25.04.2011 14:20

Die Kodierung mit Hilfe der php mcrypt extension wurde geändert.

Diese Methode war nicht CharSet sicher. Das hatte insofern keinen Einfluss da wo die Methode ging lief es Fehlerfrei. Allerdings war dieses nicht leicht festzustellen. Hier kam es - selbst bei der gleichen Kodierung - ab und an zu fehlerhaften De-Kodierung die aufgrund eines Fehleranfälligen base64 Kodierung erfolgt.

Es war nötig die gesamte Kodierung zu überarbeiten.

Das führt zu einer Inkompatibilität der alten Methode mit mcrypt.

Sollte jemand mcrypt genutzt haben, müssen Anpassungen erfolgen.



Erst nachlesen, dann nachdenken, dann nachfragen...
http://www.catb.org/~esr/faqs/smart-questions.html

openPHPnuke Developer

Zitieren nach oben
sortieren nach

 
Vorheriges Thema:  DB Layer Anpassungen
Nächstes Thema:  [modultheme] DB Änderung

Gehe zu: